Browse By

Configure H.323 Gatekeeper Redundancy using HSRP

Hello All,
Why Gatekeeper Redundancy? – There might be few scenarios where for some reason the router might go hard down or the link. If the Gatekeeper is down, the inter-cluster calls will not work if until and unless the GK comes up. In those cases, we will configure a redundancy between the Gatekeeper so that if in case the Primary Gatekeeper goes down, secondary will take place and will continue to work and we would be able to place inter-cluster calls. When the Primary links becomes available, the traffic will switch over to primary again. This can be achieved using HSRP (Hot Standby Routing Protocol). Now the question is how? Let’s start.
 
Gatekeeper-Redundancy
 
We have two Branch locations named as BR-1 and BR-2. The Branch locations are connected to the Gatekeeper in HQ site via a link. Now we have two Gatekeepers named as Gatekeeper-HQ1 and Gatekeeper-HQ2 connected via a switch which is required for running HSRP for redundancy purpose. BR-1 having extension range 1XXX and BR-2 having extension range 2XXX.
Note: – HSRP Virtual Interface IP Address is 30.1.1.250
Assuming you know the basic configuration and have done basic routing from BR-1 to BR-2. I will just provide the basic configuration used in the site.
BR-1

interface FastEthernet0/0
ip address 10.1.1.50 255.255.255.0
speed auto
full-duplex
h323-gateway voip interface
h323-gateway voip id BR-1 ipaddr 30.1.1.250 1719
h323-gateway voip h323-id BR-1
h323-gateway voip bind srcaddr 10.1.1.50
 

BR-2

interface FastEthernet0/0
ip address 50.1.1.50 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip id BR-2 ipaddr 30.1.1.250 1719
h323-gateway voip h323-id BR-2
h323-gateway voip bind srcaddr 50.1.1.50
 

Gatekeeper-HQ1

interface FastEthernet0/0
ip address 30.1.1.99 255.255.255.0
duplex auto
speed auto
standby 250 ip 30.1.1.250
standby 250 priority 110
standby 250 preempt
gatekeeper
zone local BR-2 mydomain.com 30.1.1.250
zone local BR-1 mydomain.com
zone prefix BR-2 2…
no shutdown

 
Gatekeeper-HQ2

interface FastEthernet0/0
ip address 30.1.1.199 255.255.255.0
duplex auto
speed auto
standby 250 ip 30.1.1.250
standby 250 priority 90
standby 250 preempt
 
gatekeeper
zone local BR-2 mydomain.com 30.1.1.250
zone local BR-1 mydomain.com
zone prefix BR-1 1…
zone prefix BR-2 2…
no shutdown
 

You are done with the configuration and now it’s the time to verify HSRP status.

TESTING PHASE

Gatekeeper-Redundancy-HSRP-Status
 
We could see the status to be up and Gatekeeper-HQ1 is Active Router and Gatekeeper-HQ2 is the Standby Router.
Now we need to ensure that the calls from BR-1 (1XXX) are going through to BR-2 (2XXX) without issues. Let’s verify.
 
Gatekeeper-Redundancy-BR-1-to-BR-2
 
We could see that a call was made from the extension 1000 to extension has been through and could see the call to be established successfully.
Now we need to ensure that calls via the Gatekeeper-HQ-2 should go through if the Primary Gatekeeker-HQ1 goes down. To test this, we will shut down the link of Gatekeeper-HQ1 and verify. Let’s do it.
 
Gatekeeper-Redundancy-BR1-Shutdown
 
We could see that the Gatekeeper HQ-1 is shutdown now. Now it’s time to verify if the Secondary HSRP has become Active in Gatekeeper-HQ2.
 
Gatekeeper-Redundancy-BR-2-HSRP
 
Now we could see that Gatekeeper-HQ2 has taken over and is currently Active however standby is unknown as the link is still down. Now let’s ensure that the calls are going through from BR-1 (1XXX) to BR-2 (2XXX)
 
Gatekeeper-Redundancy-BR-1-BR2-HSRP-Call
 
We could see that a call has been established via the Gatekeeper-HQ2 even the Gatekeeper-HQ1 is down. Now we will unshut the interface at Gatekeeper-HQ1 and see if the failover happens automatically.
 
Gatekeeper-Redundancy-BR-1-HSRP-State-Change
 
As soon as we brought the interface back, the status of Gatekeeper-HQ1 has taken over and became active and Gatekeeper-HQ2 is standby.
Hence our lab is successful.
Cheers!!!

Published by Team UC Collabing

Leave a Reply

Your email address will not be published. Required fields are marked *

Approved
Claudio Quiroz Cabello

Electrical Engineer CCNA Collaboration CCNA Voice CCNA R&S. I'm Electrical Engineer and I work like Support Engineer for a Telephony Service Provider Company. Before that I had position like Pre-Sale Engineer about small and medium multivendor telephony solutions. I have 5 years of experience working in Telephony Multivendor Projects. I am also 3 years of experience working in Support and implementation about Cisco Collaboration platforms: UCS server, UCM, Cisco Unity, Presence Server, Jabber, Gateway. Support Community is most useful in finding design, implementation and support tricks and shortcuts that greatly help me in my daily activities. If you need to contact me, please you can writte me.

Approved
Kanishka Singh

CCNA Routing and Switching
Am a technology enthusiast. I work in network support providing support with implementation, maintaining and precisely troubleshooting the infra.
Realm of collaboration makes me want to learn and face new challenges more and more.