Configure H323 Gatekeeper

A Gatekeeper is an H.323 device that provides services like Address Translation, Bandwidth Management, Accounting and Dial Plans that helps to centralize in order to provide scalability. Let’s say, you have 5 sites with different dial-patterns/plans and you might want to route the calls, imagine how many dial-peer you might have to create in each gateways for each individual sites. With the help of Gatekeeper, you can reduce the dial-plan which also ease us in troubleshooting.
How to configure Gatekeeper?
 Gatekeeper
Scenario :- Site A (R1) connected to Site B (R3) via Gatekeeper. Now, if Site A wants to call Site B, the call will go via Gatekeeper.
Configuration : –

R1 Gatekeeper R3
interface FastEthernet0/0
ip address 10.1.1.50 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip id R1-CME ipaddr 60.1.1.1 1719
h323-gateway voip h323-id R1-CME
h323-gateway voip bind srcaddr 10.1.1.50
!
interface FastEthernet0/1
ip address 20.1.1.100 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!!
dial-peer voice 100 voip
destination-pattern 2…
session target ras
!
gateway
timer receive-rtp 1200
!!
telephony-service
max-ephones 3
max-dn 3
ip source-address 10.1.1.50 port 2000
auto assign 1 to 3
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 8 gain -6
transfer-system full-consult
!
!
ephone-dn 1
number 1000
!
!
ephone-dn 2
number 1001
!
!
ephone-dn 3
number 1002
!
!
ephone 1
mac-address 0000.0000.0001
type 7960
button 1:1
interface Loopback0
ip address 60.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 20.1.1.150 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 30.1.1.150 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 10.1.1.0 255.255.255.0 FastEthernet0/0
ip route 40.1.1.0 255.255.255.0 FastEthernet0/1
!!
!
!
!
gatekeeper
zone local R1-CME mydomain.com 60.1.1.1
zone local R3-CME mydomain.com
zone prefix R1-CME 1…
zone prefix R3-CME 2…
no shutdown
!
interface FastEthernet0/0
ip address 30.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 40.1.1.50 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip h323-id R3-CME
h323-gateway voip bind srcaddr 40.1.1.50
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!!
dial-peer voice 100 voip
destination-pattern 1…
session target ras
!
gateway
timer receive-rtp 1200!
telephony-service
max-ephones 3
max-dn 3
ip source-address 40.1.1.50 port 2000
auto assign 1 to 3
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 8 gain -6
transfer-system full-consult
!
!
ephone-dn 1
number 2000
!
!
ephone-dn 2
number 2001
!
!
ephone-dn 3
number 2002
!
!
ephone 1
mac-address 0000.0000.0002
type 7960
button 1:1
!
!
!
ephone 2
!
!
!
ephone 3
!

You are done with the configuration now and it’s the time to test the configuration by making a test call.
Testing :- I will dial from Site A – Extension 1000 to Site B – Extension 2000 and will see if the calls are going through.
Gatekeeper-Site-A-Site-B-Call
Gatekeeper-Call-Status-SiteA-SiteB
 
Now you could see that the call status from Site A to Site B is shown at the Gatekeeper router. The call details include the duration, IP Address of the respective site, extension details, Port Number and Bandwidth.
Also you can check the Gatekeeper Status and Endpoints registration.
 
GatekeeperStatus-Endpoints
Cheers!!

You may also like...

2 Responses

  1. Claudio says:

    Hello Avinash,
    Why didn´t set technology prefixes in your example?
    Which interface, on Gatekeeper, would you consider, if don´t set the loopback (zone local)?

  2. Diana says:

    Do you use GNS3? How to add a IP-phone there?

Leave a Reply

Your email address will not be published. Required fields are marked *